lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Srinivas Kashyap <srini...@tradestonesoftware.com>
Subject Solr facet on facet field returns junk values
Date Wed, 16 May 2018 10:41:13 GMT
Hello,

I have a Solr collection which has around 20 fields(indexed and stored). When I turn on facet
and mention a facet.field, I'm able to get the facet count for that field. However, I'm able
to see some junk facet counts like below, being generated in the facet response(1, 10, 100,
1000, 100000 .......). These junk values have count 0. However, when I query(*:*) and turn
on facet.field, these junk values doesn't show up since the actual count values would be more.
Any reason why is it happening?

"PHY_KEY1": [
        "85",
        11,
        "400",
        10,
        "218",
        9,
        "965",
        9,
        "640",
        5,
        "26",
        3,
        "465",
        3,
        "292",
        2,
        "158",
        1,
        "267",
        1,
        "38",
        1,
        "00176",
        0,
        "1",
        0,
        "10",
        0,
        "100",
        0,
        "1000",
        0,
        "100000",
        0,
        "1000001",
        0,
        "1000003",
        0,
        "1000004",
        0,
        "1000005",
        0,
        "1000007",
        0,
        "1000008",
        0,
        "1000009",
        0,
        "100001",
        0,
        "1000010",
        0,
        "1000015",
        0,
        "1000017",
        0,
        "100002",
        0,
        "1000020",
        0,
        "1000022",
        0,
        "1000023",
        0,
        "1000024",
        0,
        "1000025",
        0,
        "1000026",
        0,
        "1000027",


Thanks and Regards,
Srinivas Kashyap

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message