lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <apa...@elyograg.org>
Subject Re: Java 9 and Solr 6.6
Date Fri, 01 Dec 2017 23:37:05 GMT
On 12/1/2017 12:32 PM, marotosg wrote:
> Would you recommend installing Solr 6.6.1 with Java 9 for a production
> environement?

Solr 7.x has been tested with Java 9 and should work with no problems. 
I believe that code changes were required to achieve this compatibility,
so 6.6 might have issues with Java 9.

The release information for 6.6 only mentions Java 8, while the release
information for 7.0 explicitly says that it works with Java 9.

I would not try running 6.6 with Java 9 in production without first
testing every part of the implementation on a dev server ... and based
on the limited information I know about, I'm not confident that those
tests would pass.

Thanks,
Shawn


Mime
View raw message