lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Pruitt <bpru...@opentext.com>
Subject Collection creation timeout
Date Wed, 06 Dec 2017 18:32:43 GMT
I have three SolrCloud nodes.  Two are VM's, the other is my machine.  I start Solr on each
and they report running in SolrCloud mode.  I can access each node via the admin console.

I have a configset uploaded to my ZK ensemble.

I next tried creating a collection via the admin console for my machine with the Add Collection
form.  My uploaded config set shows up ok.  I set numShards to 3 and replication factor to
1.  maxShardsPer, I leave at the default of 1.

After clicking Add Collection to create it, I get a Solr lost connection error and the admin
console is frozen.  Looking at the log I have
   o.a.s.s.HttpSolrCall null:org.apache.solr.common.SolrException: create the collection time
out:180s

When I open the admin console on the two VM's I see the collection and the graph shows my
three shards distributed across all three machines.  The two VM's are green, but the vector
for my machine not active.  When I click on it.  I get something suggesting a SSL connection
issue.  This is a development install, so I have not messed security.

When I look at the two VM's, they have the data folder for the collection.  My machine does
not.

I tried deleting the collection from the admin console for one of the VM's and I got the same
Solr connection lost error and the admin console is frozen.  However, it looks like the collection
was deleted because the VM's collection folder under the data folder is gone.

I don't understand why the collection seems to be created on the two VMs', but not on my machine.
 I have an environmental issue, but not sure where to look.

Mime
View raw message