lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adrian H <adib...@gmail.com>
Subject install_solr_service.sh issues with SUSE SLES 12.1, 12.2
Date Wed, 30 Aug 2017 13:02:08 GMT
hi all

I've installed Solr 6.6.0 (and older versions) on a couple of SUSE 
servers and ran into the following issues with the service installer script:

1) on both SLES 12.1 and 12.2:
line 196:  service --version &>/dev/null || print_error "Script requires 
the 'service' command"

service --version
exits with an exit code of 1 so the script stops there.  There is no 
--version option in the SUSE packaged service command, so it's an error.

changing this to:
service --help
resolves the issue as it exits with a 0. I can confirm that --help also 
exits with a 0 on my debian 9 system, but I don't know about the others.

2) only on SLES 12.2 (and Leap 42.2) and possibly future versions:

related to the following change:
https://www.suse.com/releasenotes/x86_64/SUSE-SLES/12-SP2/#fate-320973

On a fresh install, the command "service solr start" will result in the 
message: solr is neither service nor target!?

adding "systemctl daemon-reload" before starting the service fixes this 
issue, however, I'm not sure if this is the right approach.


I'm new to this mailing list and project, so I don't know if these are 
issues which should be created in JIRA or first discussed here.

cheers
Adrian

Mime
View raw message