lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Parker <dpar...@utica.edu>
Subject Adding a Basic Authentication user fails with 404
Date Wed, 07 Jun 2017 00:05:33 GMT
Hello,

I am running a stand-alone instance of Solr 6.5 (without ZooKeeper).  I am
attempting to implement Basic Authentication per the documentation, but
when I try to use the API to add a user, I get a 404 error.  It seems the
/admin/authentication API entry point isn't there:

$ curl --user solr:SolrRocks http://localhost:8983/solr/admin/authentication
-H 'Content-type:application/json' -d '{"set-user": {"myuser" :
"mypasswd"}}'
<html>
<head>
<meta http-equiv="Content-Type" content="text/html;charset=utf-8"/>
<title>Error 404 Not Found</title>
</head>
<body><h2>HTTP ERROR 404</h2>
<p>Problem accessing /solr/admin/authentication. Reason:
<pre>    Not Found</pre></p>
</body>
</html>

But according to the documentation, the API entry point is
admin/authentication, and it states the following:

"This endpoint is not collection-specific, so users are created for the
entire Solr cluster. If users need to be restricted to a specific
collection, that can be done with the authorization rules."

The only thing which stands out to me is "users are created for the entire
Solr cluster."  Is this entry point missing because I'm running Solr
stand-alone?

Any help is greatly appreciated!

    - Dave

-- 
Dave Parker
Database & Systems Administrator
Utica College
Integrated Information Technology Services
(315) 792-3229
Registered Linux User #408177

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message