lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Yacyshyn <ryan.yacys...@gmail.com>
Subject Re: Building Solr greater than 6.2.1
Date Mon, 01 May 2017 13:00:43 GMT
I was using Java 8 all along but more specifically, it was 1.8.0_25 (full
details below).

java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

I initially didn't think it was my Java version so I just cleared my ivy
cache and tried building again but it failed. Only after updating to:

java version "1.8.0_131"
Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)

did it work.

Regards,
Ryan



On Mon, 1 May 2017 at 20:44 Shawn Heisey <apache@elyograg.org> wrote:

> On 5/1/2017 6:34 AM, Ryan Yacyshyn wrote:
> > Thanks Alex, it's working now. I had to update Java.
>
> What version were you using?  Lucene/Solr 6 requires Java 8.  I don't
> think that building 6.2.1 would have been successful if it weren't Java 8.
>
> I'm not familiar with any specific Java release requirements (more
> specific than version 8) for any 6.x version.
>
> Thanks,
> Shawn
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message