lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From BrianMaltzan <brian.malt...@gmail.com>
Subject Re: can't create collection using solrcloud
Date Wed, 31 May 2017 15:23:38 GMT
Hi,

I disabled SSL/TLS- now creating a collection works.
 
To re-enable ssl, I've tried upgrading Zookeeper's java from 7 to 8. Solr
was already java8. Now I'm thinking there's a solr.in.sh parameter that's
new, since solr 5, that I'm still missing,
or the certificate has some issue, maybe the SNI verification is failing.

The java exception I'm seeing is unusual, in that I'm connecting to solr
with http*s*, but the log shows http:
  org.apache.solr.client.solrj.SolrServerException: IOException ocurred when
talking to server at:
  http://solr2.test.x.org:8983/solr

Thanks for the post Mangesh and Susheel, and email from Bernd! You're ideas
were helpful in narrowing down the cause. When using the
gui/terminal/web-api to create a collection, each give me the same error. I
did open iptables to eliminate a blocked connection.

Thanks,
Brian





--
View this message in context: http://lucene.472066.n3.nabble.com/can-t-create-collection-using-solrcloud-tp4338092p4338219.html
Sent from the Solr - User mailing list archive at Nabble.com.

Mime
View raw message