lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Feldman <shawn.feld...@gmail.com>
Subject Re: losing records during solr updates
Date Mon, 27 Mar 2017 20:10:10 GMT
Ercan, I think you responded to the wrong thread

On Mon, Mar 27, 2017 at 2:02 PM Ercan Karadeniz <ercan_karadeniz@hotmail.com>
wrote:

> 6.4.2 (latest available) or shall I use another one for familiarization
> purposes?
>
>
> ________________________________
> Von: Alexandre Rafalovitch <arafalov@gmail.com>
> Gesendet: Montag, 27. März 2017 21:28
> An: solr-user
> Betreff: Re: losing records during solr updates
>
> What version of Solr is it?
>
> Regards,
>    Alex.
> ----
> http://www.solr-start.com/ - Resources for Solr users, new and experienced
> Home | Solr Start<http://www.solr-start.com/>
> www.solr-start.com
> Welcome to the collection of resources to make Apache Solr search engine
> more comprehensible to beginner and intermediate users. While Solr is very
> easy to start with ...
>
>
>
>
>
> On 27 March 2017 at 15:25, Shawn Feldman <shawn.feldman@gmail.com> wrote:
> > When we restart solr on a leader node while we are doing updates, we've
> > noticed that some small percentage of data is lost.  maybe 9 records out
> of
> > 1k.  Updating using min_rf=3 or full quorum seems to resolve this since
> our
> > rf = 3.  Updates then seem to only succeed when all nodes are back up.
> Why
> > would we see record loss during a node restart?  I assumed the
> transaction
> > log would get replayed.  We have a 4 node cluster with 24 shards.
> >
> > -shawn
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message