lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexandre Rafalovitch <arafa...@gmail.com>
Subject Re: Solr shingles is not working in solr 6.4.0
Date Thu, 16 Mar 2017 16:50:00 GMT
Images do not come through.

But I was wrong too. You use eDismax and pass "cust_shingle" in, so
the "df" value is irrelevant.

You definitely reloaded the core after changing definitions?
----
http://www.solr-start.com/ - Resources for Solr users, new and experienced


On 16 March 2017 at 12:37, Aman Deep Singh <amandeep.cool99@gmail.com> wrote:
> Already check that i am sending sceenshots of various senarios
>
>
> On Thu, Mar 16, 2017 at 7:46 PM Alexandre Rafalovitch <arafalov@gmail.com>
> wrote:
>>
>> Sanity check. Is your 'df' pointing at the field you think it is
>> pointing at? It really does look like all tokens were eaten and
>> nothing was left. But you should have seen that in the Analysis screen
>> too, if you have the right field.
>>
>> Try adding echoParams=all to your request to see the full final
>> parameter list. Maybe some parameters in initParams sections override
>> your assumed config.
>>
>> Regards,
>>    Alex.
>> ----
>> http://www.solr-start.com/ - Resources for Solr users, new and experienced
>>
>>
>> On 16 March 2017 at 08:30, Aman Deep Singh <amandeep.cool99@gmail.com>
>> wrote:
>> > Hi,
>> >
>> > Recently I migrated from solr 4 to 6
>> > IN solr 4 shinglefilterfactory is working correctly
>> > my configration  i
>> >
>> >     <fieldType name="text_shingle" class="solr.TextField"
>> > positionIncrementGap="100">
>> >         <analyzer type="index">
>> >          <tokenizer class="solr.WhitespaceTokenizerFactory"/>
>> >          <filter class="solr.ShingleFilterFactory" minShingleSize="2"
>> > maxShingleSize="5"
>> >                  outputUnigrams="false"
>> > outputUnigramsIfNoShingles="false" />
>> >           <filter class="solr.LowerCaseFilterFactory"/>
>> >         </analyzer>
>> >         <analyzer type="query">
>> >           <tokenizer class="solr.WhitespaceTokenizerFactory"/>
>> >          <filter class="solr.ShingleFilterFactory" minShingleSize="2"
>> > maxShingleSize="5"
>> >                  outputUnigrams="false"
>> > outputUnigramsIfNoShingles="false" />
>> >           <filter class="solr.LowerCaseFilterFactory"/>
>> >           <filter class="solr.PositionFilterFactory"/>
>> >         </analyzer>
>> >       </fieldType>
>> >
>> >
>> >
>> > But after updating to solr 6 shingles is not working ,schema is as
>> > below,
>> >
>> >         <fieldType name="text_shingle" class="solr.TextField"
>> > positionIncrementGap="100">
>> >         <analyzer type="index">
>> >          <tokenizer class="solr.WhitespaceTokenizerFactory"/>
>> >          <filter class="solr.ShingleFilterFactory" minShingleSize="2"
>> > maxShingleSize="5"
>> >                  outputUnigrams="false"
>> > outputUnigramsIfNoShingles="false" />
>> >           <filter class="solr.LowerCaseFilterFactory"/>
>> >         </analyzer>
>> >         <analyzer type="query">
>> >           <tokenizer class="solr.WhitespaceTokenizerFactory"/>
>> >          <filter class="solr.ShingleFilterFactory" minShingleSize="2"
>> > maxShingleSize="5"
>> >                  outputUnigrams="false"
>> > outputUnigramsIfNoShingles="false" />
>> >           <filter class="solr.LowerCaseFilterFactory"/>
>> >         </analyzer>
>> >       </fieldType>
>> >
>> > Although in the Analysis tab is was showing proper shingle result but
>> > when
>> > using in the queryParser it was not giving proper results
>> >
>> > my sample hit is
>> >
>> >
>> > http://localhost:8983/solr/shingel_test/select?q=one%20plus%20one&wt=xml&debugQuery=true&defType=edismax&qf=cust_shingle
>> >
>> > it create the parsed query as
>> >
>> > <str name="rawquerystring">one plus one</str>
>> > <str name="querystring">one plus one</str>
>> > <str name="parsedquery">(+())/no_coord</str>
>> > <str name="parsedquery_toString">+()</str>
>> > <lst name="explain"/>
>> > <str name="QParser">ExtendedDismaxQParser</str>

Mime
View raw message