lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steggink, Frank" <Frank.Stegg...@kadaster.nl>
Subject Bug in admin website creating collections?
Date Fri, 20 Jan 2017 08:37:47 GMT
Hi,

I'm using Solr 6.2.1  (using the Docker image solr:6.2-alpine) in cloud mode.
When creating a collection through the admin website I noticed that when numShards is being
omitted, the collection doesn't get created. I'm using implicit routing, and the documentation
[1] says that numShards is optional. A 500 error is returned. This is because the numShards
parameter is being sent, but it is empty. When this parameter is being omitted entirely, I'm
able to create a collection.
Should this be considered a bug or a "feature"? If I enter a value which is different than
the actual number of shards I'm interested in (specified by the shards field), I assume this
value is ignored, correct?

Thanks in advance,

Frank

[1] https://cwiki.apache.org/confluence/display/solr/Collections+API#CollectionsAPI-CREATE:CreateaCollection


Disclaimer:
De inhoud van dit bericht is uitsluitend bestemd voor geadresseerde.
Gebruik van de inhoud van dit bericht door anderen zonder toestemming van het Kadaster 
is onrechtmatig. Mocht dit bericht ten onrechte bij u terecht komen, dan verzoeken wij u 
dit direct te melden aan de verzender en het bericht te vernietigen. 
Aan de inhoud van dit bericht kunnen geen rechten worden ontleend.

Disclaimer:
The content of this message is meant to be received by the addressee only.
Use of the content of this message by anyone other than the addressee without the consent

of the Kadaster is unlawful. If you have received this message, but are not the addressee,

please contact the sender immediately and destroy the message.
No rights can be derived from the content of this message

Mime
View raw message