lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <apa...@elyograg.org>
Subject Re: Zookeeper version
Date Thu, 24 Nov 2016 17:02:06 GMT
On 11/24/2016 3:12 AM, Novin Novin wrote:
> I found in solr docs that "Solr currently uses Apache ZooKeeper
> v3.4.6". Can I use higher version or I have to use 3.4.6 zookeeper. 

Solr should be fine working with zookeeper servers running any 3.4.x
version.  I believe 3.4.9 is the highest stable version currently available.

It looks like Zookeeper does not follow the same release philosophy that
Solr does.  In Solr, changes in the third version number are bugfix-only
releases.  Zookeeper does appear to add new features when the third
version number changes.  They haven't had a minor release in quite a
while, but Solr makes minor releases frequently.

So far, there are only alpha releases of Zookeeper version 3.5.  One of
the big features in that version is the ability to dynamically change
the zookeeper cluster by adding or removing servers. I have no idea
whether current Solr versions will work out of the box with a 3.5 server
cluster ... but even if it does work, it won't handle the new dynamic
membership feature.  Some time after Zookeeper releases a stable 3.5
version, Solr will be updated to use it.

Thanks,
Shawn


Mime
View raw message