lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Høydahl <jan....@cominvent.com>
Subject Re: Inconsistent results with solr admin ui and solrj
Date Sat, 13 Aug 2016 21:26:38 GMT
Could it be that your cluster is not in sync, so that when Solr picks three nodes, results
will vary depending on what replica answers?

A few questions:

a) Is your index static, i.e. not being updated live?
b) Can you try to go directly to the core menu of both replicas for each shard, and compare
numDocs / maxDocs for each? Both replicas in each shard should have same count.
c) What are you querying on and sorting by? Does it happen with only one query and sorting?
d) Are there any errors in the logs?

If possible, please share some queries, responses, config, screenshots etc.

--
Jan Høydahl, search solution architect
Cominvent AS - www.cominvent.com

> 13. aug. 2016 kl. 12.10 skrev Pranaya Behera <pranaya.behera@igp.com>:
> 
> Hi,
>    I am running solr 6.1.0 with solrcloud. We have 3 instance of zookeeper and 3 instance
of solrcloud. All three of them are active and up. One collection has 3 shards, each shard
has 2 replicas.
> 
> Everytime query whether from solrj or admin ui, getting inconsistent results. e.g.
> 1. numFound is always fluctuating.
> 2. facet count shows the count for a field, filter query on that field gets 0 results.
> 3. luke requests work(not sure whether gives correct info of all the dynamic field) on
per shard not on collection when invoked from curl but doesnt work when called from solrj.
> 4. admin ui shows expanded results, same query goes from solrj, getExpandedResults()
gives 0 docs.
> 
> What would be cause of all this ? Any pointer to look for an error anything in the logs.


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message