lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <apa...@elyograg.org>
Subject Re: Solr 6.1 :: Logging -> WARN FieldTypePluginLoader
Date Thu, 18 Aug 2016 13:11:55 GMT
On 8/18/2016 3:42 AM, Rainer Gnan wrote:
> after upgrading from "Solr 5.3" to "Solr 6.1" I get the following
> logging message: -> WARN true FieldTypePluginLoader TokenFilterFactory
> is using deprecated 5.2.1 emulation. You should at some point declare
> and reindex to at least 6.0,&#8203; because 5.x emulation is
> deprecated and will be removed in 7.0

The "luceneMatchVersion" setting in your solrconfig.xml file is 5.2.1. 
It might also appear in schema.xml, but solrconfig.xml is more likely.

The message is saying "right now, the config settings you're using will
be honored, but they won't be in the future."  This message is a warning
and will not cause Solr to blow up, even in 7.0.

The first thing you'll need to do is change luceneMatchVersion to match
your Solr version -- 6.1.0 -- and reindex.

https://wiki.apache.org/solr/HowToReindex

Note that this may change how your analyzer chains defined in schema.xml
work.  The change may be obvious, it may be subtle, and in some cases it
might actually make no change at all.  I don't have a list of changes
that are made by different luceneMatchVersion settings.

One thing that luceneMatchVersion will *not* change is index format.  I
mention this because this is a common misconception.  The index format
will be decided by the version of Solr (Lucene) that you're running, not
luceneMatchVersion.

Thanks,
Shawn


Mime
View raw message