lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nuhaa All Bakry <cawan.nu...@gmail.com>
Subject Re: 500 error querying solrcloud with >1 shard
Date Mon, 04 Jul 2016 04:12:30 GMT
We’re using Solr 6.

I think it’s because of the Suggester component - it being not supported for distributed
search. I had to specify shards=shard1 for the query to work. But even then if the other shard
has nothing (I have only 1 document indexed on shard2), it still returns error below. I wonder
if that should be a concern?

Thanks for the heads up on the bug. WIll keep that in mind!

--
nuhaa
http://about.me/nuhaa

> On 2 Jul 2016, at 1:16 AM, Erick Erickson <erickerickson@gmail.com> wrote:
> 
> Hmmm, don't see anything outstanding. What version of Solr?
> Historically there have been some bugs when a shard doesn't
> happen to host any docs, which sometimes occurs when you
> are testing and just add a few docs to the collection, is that
> a possibility?
> 
> Best,
> Erick
> 
> On Thu, Jun 30, 2016 at 10:40 PM, Nuhaa All Bakry <cawan.nuhaa@gmail.com> wrote:
>> ah i see
>> 
>> https://ibin.co/2mWaie7IVxDF.png
>> 
>> Collection A:
>> https://ibin.co/2mWawhCm76cN.png
>> 
>> Collection B:
>> https://ibin.co/2mWb4BmlMom2.png
>> 
>> 
>> 
>> --
>> nuhaa
>> http://about.me/nuhaa
>> 
>>> On 1 Jul 2016, at 12:24 PM, Erick Erickson <erickerickson@gmail.com> wrote:
>>> 
>>> None of the pasted images came through, the mail server is quite aggressive
>>> about stripping them. You'll need to upload them somewhere and provide a
>>> link.
>>> 
>>> Best,
>>> Erick
>>> 
>>> On Thu, Jun 30, 2016 at 7:36 PM, nuhaa <cawan.nuhaa@gmail.com> wrote:
>>> 
>>>> hi all,
>>>> 
>>>> We have a solrcloud setup with zookeeper, and right now we're testing it
>>>> with indexing and querying.
>>>> 
>>>> 
>>>> *collection A:*
>>>> 
>>>> *collection B:*
>>>> 
>>>> 
>>>> 
>>>> I'm trying to figure out why on collection B, indexing works but querying
>>>> doesn't. I believe by looking at Collection B > Schema > Load Term
Info on
>>>> a selected field, if I can see the value histogram, that means they're
>>>> indexed successfully.
>>>> 
>>>> On collection A, indexing and querying both work.
>>>> 
>>>> This is what returned when querying on collection B:
>>>> 
>>>> {
>>>> "responseHeader":{
>>>>   "zkConnected":true,
>>>>   "status":500,
>>>>   "QTime":17,
>>>>   "params":{
>>>>     "q":"*:*",
>>>>     "indent":"on",
>>>>     "wt":"json",
>>>>     "_":"1467275265841"}},
>>>> "error":{
>>>>   "trace":"java.lang.NullPointerException\n\tat
>>>> org.apache.solr.handler.component.QueryComponent.unmarshalSortValues(QueryComponent.java:1209)\n\tat
>>>> org.apache.solr.handler.component.QueryComponent.mergeIds(QueryComponent.java:1060)\n\tat
>>>> org.apache.solr.handler.component.QueryComponent.handleRegularResponses(QueryComponent.java:759)\n\tat
>>>> org.apache.solr.handler.component.QueryComponent.handleResponses(QueryComponent.java:738)\n\tat
>>>> org.apache.solr.handler.component.SearchHandler.handleRequestBody(SearchHandler.java:426)\n\tat
>>>> org.apache.solr.handler.RequestHandlerBase.handleRequest(RequestHandlerBase.java:156)\n\tat
>>>> org.apache.solr.core.SolrCore.execute(SolrCore.java:2036)\n\tat
>>>> org.apache.solr.servlet.HttpSolrCall.execute(HttpSolrCall.java:657)\n\tat
>>>> org.apache.solr.servlet.HttpSolrCall.call(HttpSolrCall.java:464)\n\tat
>>>> org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:257)\n\tat
>>>> org.apache.solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.java:208)\n\tat
>>>> org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1668)\n\tat
>>>> org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:581)\n\tat
>>>> org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)\n\tat
>>>> org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:548)\n\tat
>>>> org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:226)\n\tat
>>>> org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1160)\n\tat
>>>> org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:511)\n\tat
>>>> org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185)\n\tat
>>>> org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1092)\n\tat
>>>> org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)\n\tat
>>>> org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:213)\n\tat
>>>> org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:119)\n\tat
>>>> org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:134)\n\tat
>>>> org.eclipse.jetty.server.Server.handle(Server.java:518)\n\tat
>>>> org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:308)\n\tat
>>>> org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:244)\n\tat
>>>> org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:273)\n\tat
>>>> org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:95)\n\tat
>>>> org.eclipse.jetty.io.SelectChannelEndPoint$2.run(SelectChannelEndPoint.java:93)\n\tat
>>>> org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.produceAndRun(ExecuteProduceConsume.java:246)\n\tat
>>>> org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.run(ExecuteProduceConsume.java:156)\n\tat
>>>> org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:654)\n\tat
>>>> org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:572)\n\tat
>>>> java.lang.Thread.run(Thread.java:745)\n",
>>>>   "code":500}}
>>>> 
>>>> Is there anything I need to do add on solrconfig.xml?? Or is there
>>>> something possibly wrong with the zookeeper/solrcloud configurations?
>>>> How can I further investigate this?
>>>> 
>>>> Any ideas is much appreciated.
>>>> 
>>>> 
>>>> regards,
>>>> nuhaa
>>>> http://about.me/nuhaa
>>>> 
>> 


Mime
View raw message