lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <>
Subject Re: Update jar file in Solr 4.4.0
Date Wed, 15 Jun 2016 15:06:21 GMT
It sounds like you were somehow getting the old jar file
rather than the new one. It _should_ have worked to just
drop the new jar file in the directory, assuming you'd
removed all traces of the old jar file...

But if you have it working now, that's what counts.


On Tue, Jun 14, 2016 at 9:31 PM, thakkar.aayush
<> wrote:
> Actually my changes in updateProcessor.0.1.jar were not reflecting
> (functionality wise). I was getting no errors.
> Well I dropped the jar file in shared folder only updateProcessor.0.1.jar .
> The entry added in solrconfig file was
> *<processor
> class="org.apache.solr.update.processor.MyUpdateProcessorFactory">*
> In /updateProcessor.0.1.jar/ I had class file with the path
> /org.apache.solr.update.processor.MyUpdateProcessorFactory/
> However I have made some changes and it is working as expected.
> *Solution that worked for me:* I changed entry in solrconfig to
> *<processor
> class="org.apache.solr.update.processor.MyUpdateProcessorFactory2">*
> Then created new jar file /updateProcessor.0.2.jar/ with following class:
> /org.apache.solr.update.processor.MyUpdateProcessorFactory2/
> Thanks for your help. I will check with team about zookeepers though :)
> Regards,
> Aayush
> First, having 5 Zookeeper nodes to manage 4 Solr nodes
> is serious overkill. Three should be more than sufficient.
> what did you put in your configuration? Does your <lib>
> directive in solrconfig.xml mention updateProcessor.0.1?
> And what error are you seeing exactly?
> When Solr starts up, part of the voluminous messages
> are where exactly it looks for jar files. So you should
> be able to see exactly what Solr is aware of.
> If you didn't specify a <lib> directive, one assumes you
> dropped the jar somewhere in the Tomcat hive. Is
> it in the right place? Did you restart Tomcat? (not sure
> this last is necessary, but just in case...)
> Best,
> Erick
> On Mon, Jun 13, 2016 at 7:22 PM, thakkar.aayush
> &lt;thakkar.aayush@&gt; wrote:
>> I have Solr cloud configuration which we run on 4 servers. We use tomcat
>> as
>> web server for solr. I have 5 zookeepers to maintain the data-replication.
>> I
>> have added a jar file with custom update processor. This is in shared
>> folder
>> which is mention in solr.xml**While creating the first version of this jar
>> file I gave the name updateProcessor.0.1.jar as the file name. Even though
>> it was shared, jar files were added in all the 4 servers.But now I have to
>> update the updateProcessor. For this I created updateProcessor0.2.jar. I
>> deleted the updateProcessor.0.1.jar from each sever and added a new one.
>> But
>> changes were not seen ?Any ideas what I am doing wrong? Should this is be
>> checked using zkcli ?
>> --
>> View this message in context:
>> Sent from the Solr - User mailing list archive at
> --
> View this message in context:
> Sent from the Solr - User mailing list archive at

View raw message