lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timothy Potter <thelabd...@gmail.com>
Subject Re: Streaming expression not hitting all replicas?
Date Mon, 23 May 2016 18:16:17 GMT
This image from the wiki kind of gives that impression to me:

https://cwiki.apache.org/confluence/download/attachments/61311194/cluster.png?version=1&modificationDate=1447365789000&api=v2

On Mon, May 23, 2016 at 11:50 AM, Erick Erickson
<erickerickson@gmail.com> wrote:
> I _think_ this is a distinction between
> serving the query and processing the results. The
> query is the standard Solr processing returning
> results from one replica per shard.
>
> Those results can be partitioned out to N Solr instances
> for sub-processing, where N is  however many worker
> nodes you specified that may or may not be host
> to any replicas of that collection.
>
> At least I think that's what's up, but then again this is
> new to me too.
>
> Which bits of the doc anyway? Sounds like some
> clarification is in order.
>
> Best,
> Erick
>
> On Mon, May 23, 2016 at 9:32 AM, Timothy Potter <thelabdude@gmail.com> wrote:
>> I've seen docs and diagrams that seem to indicate a streaming
>> expression can utilize all replicas of a shard but I'm seeing only 1
>> replica per shard (I have 2) being queried.
>>
>> All replicas are on the same host for my experimentation, could that
>> be the issue? What are the circumstances where all replicas will be
>> utilized?
>>
>> Or is this a mis-understanding of the docs?

Mime
View raw message