lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jack Krupansky <jack.krupan...@gmail.com>
Subject Re: Slor 5.5.0 : SolrException: fieldType 'booleans' not found in the schema
Date Fri, 01 Apr 2016 20:38:33 GMT
I think it's a bug...

Ah, the key clue is here:
Caused by: org.apache.solr.common.SolrException: fieldType 'booleans' not
found in the schema
    at
org.apache.solr.update.processor.AddSchemaFieldsUpdateProcessor
Factory$TypeMapping.populateValueClasses(AddSchemaFieldsUpdateProcessor
Factory.java:247)

In fact, if we look at this schema in the repo:
https://github.com/apache/lucene-solr/blob/releases/lucene-solr/5.5.0/solr/server/solr/configsets/data_driven_schema_configs/conf/solrconfig.xml

We can find this update processor chain:
<updateRequestProcessorChain name="add-unknown-fields-to-the-schema">

Which has this processor:

<processor class="solr.AddSchemaFieldsUpdateProcessorFactory"> <str
name="defaultFieldType">strings</str> <lst name="typeMapping"> <str
name="valueClass">java.lang.Boolean</str> <str
name="fieldType">booleans</str> </lst>

And there is you field type "booleans" reference.

That type used to be needed for multivalued boolean fields, but now the
dynamic pattern for *_bs is itself multivalued and simply references the
"boolean" type.

This schema in the repo has a similar issue:
https://github.com/apache/lucene-solr/blob/releases/lucene-solr/5.5.0/solr/example/files/conf/solrconfig.xml
<updateRequestProcessorChain name="files-update-processor">
<processor class="solr.AddSchemaFieldsUpdateProcessorFactory"> <str
name="defaultFieldType">strings</str> <lst name="typeMapping"> <str
name="valueClass">java.lang.Boolean</str> <str
name="fieldType">booleans</str> </lst>

Hmmm... or maybe the old "booleans" field type should be restored to allow
boolean fields to be multivalued?

So, somebody should file a Jira on this.


-- Jack Krupansky

On Fri, Apr 1, 2016 at 3:24 PM, Girish Tavag <send2mymailbox@gmail.com>
wrote:

> Hi Shawn,
>
>  Finally i'm able to figure out the problem. The issue was in
> solrconfig.xml where the booleans was defined. I replaced booleans with
> boolean and other similar fileds and it worked correctly :)
>
> Regards,
> GNT.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message