lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Salman Ansari <salman.rah...@gmail.com>
Subject Re: Problem in Issuing a Command to Upload Configuration
Date Tue, 29 Mar 2016 08:53:24 GMT
Thanks Reth for your response. It did work.

Regards,
Salman

On Mon, Mar 28, 2016 at 8:01 PM, Reth RM <reth.iksam@gmail.com> wrote:

> I think it should be "zkcli.bat" (all in lower case) that is shipped with
> solr not zkCli.cmd(that is shipped with zookeeper)
>
> solr_home/server/scripts/cloud-scripts/zkcli.bat -zkhost 127.0.0.1:9983 \
>    -cmd upconfig -confname my_new_config -confdir
> server/solr/configsets/basic_configs/conf
>
> On Mon, Mar 28, 2016 at 8:18 PM, Salman Ansari <salman.rahmat@gmail.com>
> wrote:
>
> > Hi,
> >
> > I am facing issue uploading configuration to Zookeeper ensemble. I am
> > running this on Windows as
> >
> > *Command*
> > *========*
> > zkCli.cmd -cmd upconfig -zkhost
> > "[localserver]:2181,[second_server]:2181,[third_server]:2181" -confname
> > [config_name]  -confdir "[config_dir]"
> >
> > and I got the following result
> >
> > *Result*
> > =====
> > Connecting to localhost:2181
> > 2016-03-28 14:40:12,849 [myid:] - INFO  [main:Environment@100] - Client
> > environm
> > ent:zookeeper.version=3.4.6-1569965, built on 02/20/2014 09:09 GMT
> > 2016-03-28 14:40:12,849 [myid:] - INFO  [main:Environment@100] - Client
> > environm
> > ent:host.name=SabrSolrServer1.SabrSolrServer1.a2.internal.cloudapp.net
> > 2016-03-28 14:40:12,849 [myid:] - INFO  [main:Environment@100] - Client
> > environm
> > ent:java.version=1.8.0_77
> > 2016-03-28 14:40:12,849 [myid:] - INFO  [main:Environment@100] - Client
> > environm
> > ent:java.vendor=Oracle Corporation
> > 2016-03-28 14:40:12,849 [myid:] - INFO  [main:Environment@100] - Client
> > environm
> > ent:java.home=C:\Program Files\Java\jre1.8.0_77
> > 2016-03-28 14:40:12,849 [myid:] - INFO  [main:Environment@100] - Client
> > environm
> >
> >
> ent:java.class.path=C:\Solr\Zookeeper\zookeeper-3.4.6\bin\..\build\classes;C:\So
> >
> >
> lr\Zookeeper\zookeeper-3.4.6\bin\..\build\lib\*;C:\Solr\Zookeeper\zookeeper-3.4.
> >
> >
> 6\bin\..\zookeeper-3.4.6.jar;C:\Solr\Zookeeper\zookeeper-3.4.6\bin\..\lib\jline-
> >
> >
> 0.9.94.jar;C:\Solr\Zookeeper\zookeeper-3.4.6\bin\..\lib\log4j-1.2.16.jar;C:\Solr
> >
> >
> \Zookeeper\zookeeper-3.4.6\bin\..\lib\netty-3.7.0.Final.jar;C:\Solr\Zookeeper\zo
> >
> >
> okeeper-3.4.6\bin\..\lib\slf4j-api-1.6.1.jar;C:\Solr\Zookeeper\zookeeper-3.4.6\b
> >
> >
> in\..\lib\slf4j-log4j12-1.6.1.jar;C:\Solr\Zookeeper\zookeeper-3.4.6\bin\..\conf
> > 2016-03-28 14:40:12,865 [myid:] - INFO  [main:Environment@100] - Client
> > environm
> >
> >
> ent:java.library.path=C:\ProgramData\Oracle\Java\javapath;C:\Windows\Sun\Java\bi
> >
> >
> n;C:\Windows\system32;C:\Windows;C:\ProgramData\Oracle\Java\javapath;C:\Windows\
> >
> >
> system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShe
> > ll\v1.0\;C:\Program Files\Java\JDK\bin;.
> > 2016-03-28 14:40:12,865 [myid:] - INFO  [main:Environment@100] - Client
> > environm
> > ent:java.io.tmpdir=C:\Users\ADMIN_~1\AppData\Local\Temp\2\
> > 2016-03-28 14:40:12,865 [myid:] - INFO  [main:Environment@100] - Client
> > environm
> > ent:java.compiler=<NA>
> > 2016-03-28 14:40:12,865 [myid:] - INFO  [main:Environment@100] - Client
> > environm
> > ent:os.name=Windows Server 2012 R2
> > 2016-03-28 14:40:12,865 [myid:] - INFO  [main:Environment@100] - Client
> > environm
> > ent:os.arch=amd64
> > 2016-03-28 14:40:12,865 [myid:] - INFO  [main:Environment@100] - Client
> > environm
> > ent:os.version=6.3
> > 2016-03-28 14:40:12,865 [myid:] - INFO  [main:Environment@100] - Client
> > environm
> > ent:user.name=admin_user
> > 2016-03-28 14:40:12,865 [myid:] - INFO  [main:Environment@100] - Client
> > environm
> > ent:user.home=C:\Users\admin_user
> > 2016-03-28 14:40:12,865 [myid:] - INFO  [main:Environment@100] - Client
> > environm
> > ent:user.dir=C:\Solr\Zookeeper\zookeeper-3.4.6\bin
> > 2016-03-28 14:40:12,865 [myid:] - INFO  [main:ZooKeeper@438] -
> Initiating
> > client
> >  connection, connectString=localhost:2181 sessionTimeout=30000
> > watcher=org.apach
> > e.zookeeper.ZooKeeperMain$MyWatcher@506c589e
> >
> > It looks like that it is not even calling the command. Any idea why is
> that
> > happening?
> >
> > Regards,
> > Salman
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message