lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shai Erera <ser...@gmail.com>
Subject Re: SolrJ 5.5 won't work with any of my servers
Date Tue, 01 Mar 2016 16:30:38 GMT
Ah ok, in my case even 5.4.1 didn't work with binary request writer, so
probably we don't face the same issue.

Shai

On Tue, Mar 1, 2016, 17:07 Shawn Heisey <apache@elyograg.org> wrote:

> On 2/29/2016 9:14 PM, Shai Erera wrote:
> > Shawn, not sure if it's the same case as yours, but I've hit NPEs
> upgrading
> > to 5.5 too. In my case though, SolrJ talks to a proxy servlets before the
> > request gets routed to Solr, and that servlet didn't handle binary
> content
> > stream well.
> >
> > I had to add another resource method to the servlet which handled
> > "appliation/javabin" and "application/octet-stream" and received the body
> > as an InputStream.
>
> I wish this was an NPE.  It would be easier to track down.
>
> There is no proxy.  Although I do have a load balancer (haproxy) in
> place for queries, this program doesn't use it.
>
> It looks to me like SolrJ 5.5 behaves in a way that changes what gets
> sent when talking to an existing Solr install using the default Jetty
> config.  This seems like a bug to me.
>
> I need to investigate what happens in my code when MySQL returns NULL
> values.  I suspect that the object assigned to the SolrInputDocument
> field is null.  Whatever it is that happens, SolrJ 5.4.1 works correctly
> and 5.5.0 doesn't.
>
> Thanks,
> Shawn
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message