lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <apa...@elyograg.org>
Subject Re: SolrJ 5.5 won't work with any of my servers
Date Tue, 01 Mar 2016 02:42:39 GMT
On 2/29/2016 7:01 PM, Shawn Heisey wrote:
> On 2/29/2016 6:42 PM, Shawn Heisey wrote:
>> I'm getting this stacktrace after upgrading SolrJ to 5.5.0 in my build
>> client:
>>
>> http://apaste.info/Vpg
>>
>> This is happening with 4.x, 5.3.2-SNAPSHOT, and 5.5.0-SNAPSHOT servers.
> I got a little bit closer look at the server log.  Initially it looked
> like this was a NSFE exception from Lucene (missing segments_XX file),
> which is why I sent this message.
>
> The closer look has revealed that it's a problem with a third-party
> plugin we are using.

Second followup:

Although the error came from the third-party plugin, I think there's
still something different going on with SolrJ.  The SolrJ version was
the only thing I changed in my ivy config, which made it work again.

It looks like the plugin complained about a literal string "NULL"
(uppercase) being the data that it received.  The source data comes from
MySQL.  JDBC is the only part of the program I can imagine might create
a literal string "NULL" ... but this has never happened before, and I've
been using JDBC for a long time with this program.  Also, the problem
went away by downgrading SolrJ from 5.5.0 to 5.4.1, but none of the
other separate dependencies (including the MySQL JDBC driver) were
downgraded.

The only thing that jumped out at me in CHANGES.txt is the binary
request writer changing to default in SolrJ 5.5.  I explicitly set the
writer to binary with the 5.4.1 version, and suddenly I'm having the
same problem.

How could changing the request writer cause this?

Thanks,
Shawn


Mime
View raw message