lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damien Picard <picard.dam...@gmail.com>
Subject Solr QTime explanation
Date Tue, 19 Jan 2016 10:43:19 GMT
Hi,

I'm currently testing Solr query execution performance (over http and
SolrJ), and, using HTTP with JMeter, I see that the response time increases
with the number of concurrent request (100 simultaneous request in my case).

To understand where Solr takes more time, I use the debug=timing parameter.
And I see this kind of response :

<?xml version="1.0" encoding="UTF-8"?>
<response>

<lst name="responseHeader">
  <int name="status">0</int>
  <int name="QTime">3003</int>
  <lst name="params">
    <str name="q">uuid:FA2C9342381E3969E04456C8B4C639A9</str>
    <str name="debug">timing</str>
    <str name="indent">true</str>
    <str name="wt">xml</str>
  </lst>
</lst>
<result name="response" numFound="1" start="0" maxScore="15.705477">
  <doc>
    <bool name="bc_repe_pro">false</bool>
    <str name="type_personne">P</str>
    <str name="numero_dossier_client">30000224149</str>
    <str name="uuid">FA2C9342381E3969E04456C8B4C639A9</str>
    <str name="cle_recherche">FA2C9342381E3969E04456C8B4C639A9_P</str>
    <long name="_version_">1518391139884859416</long></doc>
</result>
<lst name="debug">
  <lst name="timing">
    <double name="time">0.0</double>
    <lst name="prepare">
      <double name="time">0.0</double>
      <lst name="query">
        <double name="time">0.0</double>
      </lst>
      <lst name="facet">
        <double name="time">0.0</double>
      </lst>
      <lst name="mlt">
        <double name="time">0.0</double>
      </lst>
      <lst name="highlight">
        <double name="time">0.0</double>
      </lst>
      <lst name="stats">
        <double name="time">0.0</double>
      </lst>
      <lst name="debug">
        <double name="time">0.0</double>
      </lst>
    </lst>
    <lst name="process">
      <double name="time">0.0</double>
      <lst name="query">
        <double name="time">0.0</double>
      </lst>
      <lst name="facet">
        <double name="time">0.0</double>
      </lst>
      <lst name="mlt">
        <double name="time">0.0</double>
      </lst>
      <lst name="highlight">
        <double name="time">0.0</double>
      </lst>
      <lst name="stats">
        <double name="time">0.0</double>
      </lst>
      <lst name="debug">
        <double name="time">0.0</double>
      </lst>
    </lst>
  </lst>
</lst>
</response>

I see that the QTime is "3003", but I get nothing (0.0) for all other
times. Do you know what does it means ?

Thank you in advance.

-- 
Damien Picard
Expert GWT
<http://www.editions-eni.fr/livres/gwt-google-web-toolkit-developpez-des-applications-internet-riches-ria-en-java/.97a1a26e7d5be94763fc45ac2a1e961a.html>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message