lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zap Org <zapor...@gmail.com>
Subject Re: Solrcloud for Java 1.6
Date Tue, 12 Jan 2016 03:59:41 GMT
hello shawn yes it is written in a style readble with java 7 what i have
done is, altered the syntax into java 6 and then compile and it is 100%
working. if you need, i can send you the jar.

On Fri, Jan 8, 2016 at 11:59 AM, Shawn Heisey <apache@elyograg.org> wrote:

> On 1/7/2016 10:59 PM, Zap Org wrote:
> > i have solr5.0.0 installed in one machine with JVM specs java 1.7 32GB
> RAM
> > now from another machine i am sending query request to this machine with
> > specs JAVA 1.6
> > so what really happening solr5.0.0 (1.7) is communicating with
> > solrj5.0.0(1.6)
>
> The system with SolrJ 5.0.0 must have a newer Java version installed.
> It is simply not possible to run Solr or SolrJ 5.0.0 with Java 6.
>
> If you attempt to run version 4.8 or later with Java 6, you'll get an
> error that looks like this:
>
> Exception in thread "main" java.lang.UnsupportedClassVersionError:
> org/apache/solr/xxx/yyy: Unsupported major.minor version 51.0
>
> Here is some information about what the specific major.minor version
> number means:
>
> http://stackoverflow.com/a/11432195
>
> Just for giggles, I attempted to compile SolrJ (which is a standalone
> module not dependent on the rest of Solr) in the branch_5x checkout with
> the build script changed to produce jars compatible with version 1.6.
> It would not compile when the target was set to 1.6, because the way the
> code is written *requires* Java 7, and has since version 4.8.
>
> Thanks,
> Shawn
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message