lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Collins <danwcoll...@gmail.com>
Subject Re: Solr 5 with java 7 or java 8
Date Tue, 19 Jan 2016 15:42:05 GMT
Solr 5.x is compiled for Java7 bytecode, so it will definitely work on a
Java 7 VM.  It is Solr 6 which will be Java 8 only.

That said, I would advocate using Java 8. Especially as Java 7 is already
publicly End of Life'd, starting a new project on Java 7 would seem
short-sighted.

On 19 January 2016 at 14:41, Novin Novin <toe.alean@gmail.com> wrote:

> Hi Guys,
>
> Is this highly recommended java 8 with solr 5.x, because solr 5.x code is
> compiled with java 8
> or it would be ok with java 7 but also could cause performance .
>
> Thanks
> Novin
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message