lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Joyner <mich...@newsrx.com>
Subject Re: Rolling upgrade to 5.4 from 5.0 - "bug" caused by leader changes - is there a workaround?
Date Tue, 19 Jan 2016 21:48:43 GMT
ok,

I just found the 5.4.1 RC2 download, it seems to work ok for a rolling 
upgrade.

I will see about downgrading back to 5.4.0 afterwards to be on an 
official release ...


On 01/19/2016 04:27 PM, Michael Joyner wrote:
> Hello all,
>
> I downloaded 5.4 and started doing a rolling upgrade from a 5.0 
> solrcloud cluster and discovered that there seems to be a 
> compatibility issue where doing a rolling upgrade from pre-5.4 which 
> causes the 5.4 to fail with unable to determine leader errors.
>
> Is there a work around that does not require taking the cluster down 
> to upgrade to 5.4? Should I just stay with 5.3 for now? I need to 
> implement programmatic schema changes in our collection via solrj, and 
> based on what I'm reading this is a very new feature and requires the 
> latest (or near latest) solrcloud.
>
> Thanks!
>
> -Mike


Mime
View raw message