lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Oakley, Craig (NIH/NLM/NCBI) [C]" <craig.oak...@nih.gov>
Subject RE: Re:Re: Implementing security.json is breaking ADDREPLICA
Date Thu, 19 Nov 2015 20:36:01 GMT
I tried again with the following security.json, but the results were the same:

{
  "authentication":{
    "class":"solr.BasicAuthPlugin",
    "credentials":{
      "solr":"IV0EHq1OnNrj6gvRCwvFwTrZ1+z1oBbnQdiVC3otuq0= Ndd7LKvVBAaZIF0QAVi1ekCfAJXr1GGfLtRUXhgrF8c=",
      "solruser":"VgZX1TAMNHT2IJikoGdKtxQdXc+MbNwfqzf89YqcLEE= 37pPWQ9v4gciIKHuTmFmN0Rv66rnlMOFEWfEy9qjJfY="},
    "":{"v":9}},
  "authorization":{
    "class":"solr.RuleBasedAuthorizationPlugin",
    "user-role":{
      "solr":[
        "admin",
        "read",
        "xmpladmin",
        "xmplgen",
        "xmplsel"],
      "solruser":[
        "read",
        "xmplgen",
        "xmplsel"]},
    "permissions":[
      {
        "name":"security-edit",
        "role":"admin"},
      {
        "name":"xmpl_admin",
        "collection":"xmpl",
        "path":"/admin/*",
        "role":"xmpladmin"},
      {
        "name":"xmpl_sel",
        "collection":"xmpl",
        "path":"/select/*",
        "role":null},
      {
         "name":"all-admin",
         "collection":null,
         "path":"/*",
         "role":"xmplgen"},
      {
         "name":"all-core-handlers",
         "path":"/*",
         "role":"xmplgen"}],
    "":{"v":42}}}

-----Original Message-----
From: Oakley, Craig (NIH/NLM/NCBI) [C] 
Sent: Thursday, November 19, 2015 1:46 PM
To: 'solr-user@lucene.apache.org' <solr-user@lucene.apache.org>
Subject: RE: Re:Re: Implementing security.json is breaking ADDREPLICA

I note that the thread called "Security Problems" (most recent post by Nobel Paul) seems like
it may help with much of what I'm trying to do. I will see to what extent that may help.

Mime
View raw message