lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anders Thulin <anders.thu...@comintelli.com>
Subject Re: Run Solr 5.3.0 as a Service on Windows using NSSM
Date Wed, 14 Oct 2015 15:44:21 GMT
Did you add the f param for running it in foreground?
I noticed that the Solr service was restarted indefinetly when running it
as a background service.
its also needed to stop the windows service.

This test worked well here (on Windows 2012):

REM Test for running solr 5.3.1 as a windows service
C:\nssm\nssm64.exe install "Solr 5.3.1" C:\search\solr-5.3.1\bin\solr.cmd
"start -f -p 8983"

On 8 October 2015 at 04:34, Zheng Lin Edwin Yeo <edwinyeozl@gmail.com>
wrote:

> Hi Adrian and Upayavira,
>
> It works fine when I start Solr outside NSSM.
> As for the NSSM, so far I haven't tried the automatic startup yet. I start
> the services for ZooKeeper and Solr in NSSM manually from the Windows
> Component Services, so the ZooKeeper will have been started before I start
> Solr.
>
> I'll also try to write the script for Solr that can check it can access
> Zookeeper before attempting to start Solr.
>
> Regards,
> Edwin
>
>
> On 7 October 2015 at 19:16, Upayavira <uv@odoko.co.uk> wrote:
>
> > Wrap your script that starts Solr with one that checks it can access
> > Zookeeper before attempting to start Solr, that way, once ZK starts,
> > Solr will come up. Then, hand *that* script to NSSM.
> >
> > And finally, when one of you has got a setup that works with NSSM
> > starting Solr via the default bin\solr.cmd script, create a patch and
> > upload it to JIRA. It would be a valuable thing for Solr to have a
> > *standard* way to start Solr on Windows as a service. I recall checking
> > the NSSM license and it wouldn't be an issue to include it within Solr -
> > or to have a script that assumes it is installed.
> >
> > Upayavira
> >
> > On Wed, Oct 7, 2015, at 11:49 AM, Adrian Liew wrote:
> > > Hi Edwin,
> > >
> > > You may want to try explore some of the configuration properties to
> > > configure in zookeeper.
> > >
> > >
> >
> http://zookeeper.apache.org/doc/r3.4.5/zookeeperAdmin.html#sc_zkMulitServerSetup
> > >
> > > My recommendation is to try run your batch files outside of NSSM so it
> is
> > > easier to debug and observe what you see from the command window. I
> don't
> > > think ZK and Solr can be automated on startup well using NSSM due to
> the
> > > fact that ZK services need to be running before you start up Solr
> > > services. I just had conversation with Shawn on this topic. NSSM cannot
> > > do the magic startup in a cluster setup. In that, you may need to write
> > > custom scripting to get it right.
> > >
> > > Back to your original issue, I guess it is worth exploring timeout
> > > values. Then again, I will leave the real Solr experts to chip in their
> > > thoughts.
> > >
> > > Best regards,
> > >
> > > Adrian Liew
> > >
> > >
> > > -----Original Message-----
> > > From: Zheng Lin Edwin Yeo [mailto:edwinyeozl@gmail.com]
> > > Sent: Wednesday, October 7, 2015 1:40 PM
> > > To: solr-user@lucene.apache.org
> > > Subject: Re: Run Solr 5.3.0 as a Service on Windows using NSSM
> > >
> > > Hi Adrian,
> > >
> > > I've waited for more than 5 minutes and most of the time when I refresh
> > > it says that the page cannot be found. Got one or twice the main Admin
> > > page is loaded, but none of the cores are loaded.
> > >
> > > I have 20 cores which I'm loading. The core are of various sizes, but
> the
> > > maximum one is 38GB. Others ranges from 10GB to 15GB, and there're some
> > > which are less than 1GB.
> > >
> > > My overall core size is about 200GB.
> > >
> > > Regards,
> > > Edwin
> > >
> > >
> > > On 7 October 2015 at 12:11, Adrian Liew <adrian.liew@avanade.com>
> wrote:
> > >
> > > > Hi Edwin,
> > > >
> > > > I have setup NSSM on Solr 5.3.0 in an Azure VM and can start up Solr
> > > > with a base standalone installation.
> > > >
> > > > You may have to give Solr some time to bootstrap things and wait for
> > > > the page to reload. Are you still seeing the page after 1 minute or
> so?
> > > >
> > > > What are your core sizes? And how many cores are you trying to load?
> > > >
> > > > Best regards,
> > > > Adrian
> > > >
> > > > -----Original Message-----
> > > > From: Zheng Lin Edwin Yeo [mailto:edwinyeozl@gmail.com]
> > > > Sent: Wednesday, October 7, 2015 11:46 AM
> > > > To: solr-user@lucene.apache.org
> > > > Subject: Run Solr 5.3.0 as a Service on Windows using NSSM
> > > >
> > > > Hi,
> > > >
> > > > I tried to follow this to start my Solr as a service using NSSM.
> > > > http://www.norconex.com/how-to-run-solr5-as-a-service-on-windows/
> > > >
> > > > Everything is fine when I start the services under Component
> Services.
> > > > However, when I tried to point to the Solr Admin page, it says that
> > > > the page cannot be found.
> > > >
> > > > I have tried the same thing in Solr 5.1, and it was able to work. Not
> > > > sure why it couldn't work for Solr 5.2 and Solr 5.3.
> > > >
> > > > Is there any changes required to what is listed on the website?
> > > >
> > > > Regards,
> > > > Edwin
> > > >
> >
>



-- 
Kind Regards / Med vänlig hälsning



*Anders Thulin*

Founder, CTO

__________________________________________________________________________________


*Comintelli*®

Kista Science Tower | S-164 51 Kista, Sweden

Internet: *www.comintelli.com <http://www.comintelli.com/>*

E-mail: anders.thulin@comintelli.com | Skype: andersthulin

Phone: +46 70 622 9832

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message