lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From shacky <shack...@gmail.com>
Subject Error in creating a new collection
Date Thu, 03 Sep 2015 06:58:52 GMT
Hi,
I have a three nodes Solr 5.3.0 cluster with Zookeeper 3.4.5.
New collections are creating without any problem, so the cluster seems
to work well.
I created a new collection "test2" using an old configuration, and I
got this error:

enablePositionIncrements is not a valid option as of Lucene 5.0

So I removed that value in the configuration and tried to recreate the
new collection, but I'm getting the same error, even if now the
enablePositionIncrements parameter is not in the configuration file.

I also tried creating the same collection with the default configset
but I'm still having the same error:

root@index1:~# /opt/solr/bin/solr create_collection -c test2
-replicationFactor 3

Connecting to ZooKeeper at
index1.dc.ems.network:2181,index2.dc.ems.network:2181,index3.dc.ems.network:2181/solr
...
Re-using existing configuration directory test2

Creating new collection 'test2' using command:
http://localhost:8983/solr/admin/collections?action=CREATE&name=test2&numShards=1&replicationFactor=3&maxShardsPerNode=1&collection.configName=test2

ERROR: Failed to create collection 'test2' due to:
org.apache.solr.client.solrj.impl.HttpSolrClient$RemoteSolrException:Error
from server at http://index2.dc.ems.network:8983/solr: Error CREATEing
SolrCore 'test2_shard1_replica3': Unable to create core
[test2_shard1_replica3] Caused by: enablePositionIncrements is not a
valid option as of Lucene 5.0

If I use a new different name (like "test3") I can create the
collection without any problem:

root@index1:~# /opt/solr/bin/solr create_collection -c test3
-replicationFactor 3

Connecting to ZooKeeper at
index1.dc.ems.network:2181,index2.dc.ems.network:2181,index3.dc.ems.network:2181/solr
...
Uploading /opt/solr/server/solr/configsets/data_driven_schema_configs/conf
for config test3 to ZooKeeper at
index1.dc.ems.network:2181,index2.dc.ems.network:2181,index3.dc.ems.network:2181/solr

Creating new collection 'test3' using command:
http://localhost:8983/solr/admin/collections?action=CREATE&name=test3&numShards=1&replicationFactor=3&maxShardsPerNode=1&collection.configName=test3

{
  "responseHeader":{
    "status":0,
    "QTime":3175},
  "success":{"":{
      "responseHeader":{
        "status":0,
        "QTime":3040},
      "core":"test3_shard1_replica1"}}}

So I'm thinking about a "lock" problem or something like that.

Could you help me please?

Thank you very much!
Bye

Mime
View raw message