lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roshan Agarwal <ros...@siddhast.com>
Subject Re: solrcloud not displaying store fields
Date Wed, 23 Sep 2015 05:47:02 GMT
Further in this please see an example below:


http://solr:port
/solr/cloud1_shard1_replica1/select?q=UCID%3Addfdf4&fl=UCID&wt=json&indent=true

{
  "responseHeader":{
    "status":0,
    "QTime":1157,
    "params":{
      "q":"UCID:ddfdf4",
      "indent":"true",
      "fl":"UCID",
      "wt":"json"}},
  "response":{"numFound":1,"start":0,"maxScore":13.710121,"docs":[
      {
        "UCID":"ddfdf4"}]
  },


But when we add TI in fl there is no num found

http://solr:port/solr/cloud1_shard1_replica1/select?q=UCID%3Addfdf4&fl=UCID,TI&wt=json&indent=true

{
  "responseHeader":{
    "status":0,
    "QTime":1727,
    "params":{
      "q":"UCID:ddfdf4",

      "indent":"true",
      "fl":"UCID,TI",
      "wt":"json"}},
  "response":{"numFound":0,"start":0,"maxScore":13.710121,"docs":[]
  },
  "highlighting":{},
  "spellcheck":{
    "suggestions":[]}}

Can any one explain this behaviour of solr


Roshan




On Wed, Sep 23, 2015 at 11:06 AM, Roshan Agarwal <roshan@siddhast.com>
wrote:

> I am getting an issue with solrcloud the stored field is not reflecting in
> search where as we are able to get result
>



-- 

Roshan Agarwal
Director sales
Siddhast Ip innovation (P) ltd
907 chandra vihar colony
Jhansi-284002
M:+919871549769
M:+917376314900

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message