lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: Deadlock-like behavior when new IndexWriter created
Date Tue, 11 Aug 2015 16:04:23 GMT
Hmm, it would be _really_ helpful if next time it happens you could
get a stack trace (see jstack, should have come with your Java). As it
happens we're chasing another deadlock and it'd be interesting to see
if they're related.

Thanks!
Erick

On Tue, Aug 11, 2015 at 1:12 AM, Andrii Berezhynskyi
<andrii.berezhynskyi@home24.de> wrote:
> Hi,
>
> I have solr5.2.1 set up in master-slave configuration. Very often it
> happens that solr slave starts replicating (I can see it in admin panel)
> but it is getting stuck at 0% and never proceeds further. Usually restart
> of slave helps.
>
> Relevant logs from slave:
>
> INFO  - 2015-08-11 07:56:00.184; org.apache.solr.handler.IndexFetcher;
> Master's generation: 26
> INFO  - 2015-08-11 07:56:00.188; org.apache.solr.handler.IndexFetcher;
> Slave's generation: 25
> INFO  - 2015-08-11 07:56:00.189; org.apache.solr.handler.IndexFetcher;
> Starting replication process
> INFO  - 2015-08-11 07:56:00.205; org.apache.solr.handler.IndexFetcher;
> Number of files in latest index in master: 10
> INFO  - 2015-08-11 07:56:00.209;
> org.apache.solr.core.CachingDirectoryFactory; return new directory for
> /var/solr/data/catalog_article_1_de_DE/data/index.20150811075600209
> *INFO  - 2015-08-11 07:56:00.212;
> org.apache.solr.update.DefaultSolrCoreState; Creating new IndexWriter...*
> *INFO  - 2015-08-11 07:56:00.221;
> org.apache.solr.update.DefaultSolrCoreState; Waiting until IndexWriter is
> unused... core=catalog_article_1_de_DE*
> INFO  - 2015-08-11 07:56:00.522; org.apache.solr.core.SolrCore;
> [catalog_article_1_de_DE] webapp=/solr path=/select params={} hits=0
> status=0 QTime=1
> INFO  - 2015-08-11 07:56:03.654; org.apache.solr.core.SolrCore;
> [catalog_article_1_de_DE] webapp=/solr path=/select params={} hits=0
> status=0 QTime=1
> ....
>
> here is relevant solrconfig.xml entries:
>
> <updateHandler class="solr.DirectUpdateHandler2">
>     <updateLog>
>       <str name="dir">${solr.catalog_article_1_de_DE.data.dir:}</str>
>     </updateLog>
>
>     <autoCommit>
>       <maxDocs>10000</maxDocs>
>       <maxTime>300000</maxTime>
>       <openSearcher>false</openSearcher>
>     </autoCommit>
>     <autoSoftCommit>
>          <maxTime>15000</maxTime>
>      </autoSoftCommit>
>   </updateHandler>
>
> <requestHandler name="/replication" class="solr.ReplicationHandler">
>       <lst name="master">
>         <str name="enable">${enable.master:false}</str>
>         <str name="replicateAfter">optimize</str>
>         <str name="confFiles">schema.xml,solrconfig.xml</str>
>       </lst>
>       <lst name="slave">
>         <str name="enable">${enable.slave:false}</str>
>         <str name="masterUrl">${master.url:127.0.0.1:8983}/${solr.core.name
> }</str>
>         <str name="pollInterval">00:01:00</str>
>       </lst>
>     </requestHandler>
>
> Has anybody faced the same problem?
> Is it master's or slave's issue?
> How can I debug/fix the problem?
>
> Thanks
> Andrii

Mime
View raw message