lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Summer Shire <shiresum...@gmail.com>
Subject invalid index version and generation
Date Mon, 15 Jun 2015 04:40:08 GMT
Hi all,

Every time I optimize my index with maxSegment=2 after some time the replication fails to
get filelist for a given generation. Looks like the index version and generation count gets
messed up.
(If the maxSegment=1 this never happens. I am able to successfully reproduce this by optimizing
with maxSegment=2. I am using solr 4.7.2)
eg: SnapPuller    - No files to download for index generation: 67

Here is what I see when I curl the commands on my terminal.
I also tried to modify the snapPullers fetchFileList(long gen) method to get indexVersion
and pass that as a param but that did not help either.
Also my slave gen/version is always smaller than master. 

What could be going on? any idea ?

Thanks,
Summer

$ curl "http://localhost:6600/solr/main0/replication?command=indexversion"
<?xml version="1.0" encoding="UTF-8"?>
<response>
<lst name="responseHeader"><int name="status">0</int><int name="QTime">0</int></lst><long
name="indexversion">1434341174641</long><long name="generation">67</long>
</response>

$ curl "http://localhost:6600/solr/main0/replication?command=filelist&generation=67&indexversion=1434341174641"
<?xml version="1.0" encoding="UTF-8"?>
<response>
<lst name="responseHeader"><int name="status">0</int><int name="QTime">0</int></lst><str
name="status">invalid index generation</str>
</response>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message