lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tuxedomoon <dancolem...@yahoo.com>
Subject Re: SolrCloud 5.1 startup looking for standalone config
Date Tue, 02 Jun 2015 18:16:20 GMT
I ran this command with Solr hosts s1 & s2 running.  

http://s1:8983/solr/admin/collections?action=CREATE&name=mycollection&numShards=2&collection.configName=mycollection_cloud_conf&createNodeSet=s1:8983,s2:8983

I referred to  this link
<http://heliosearch.org/solrcloud-assigning-nodes-machines/>   which looks
like it is only passing the desired leaders to createNodeSet.

But I'm getting this error
-----------------------------------------------------------------------------------------
Cannot create collection mycollection. Value of maxShardsPerNode is 1, and
the number of nodes currently live or live and part of your createNodeSet is
0. This allows a maximum of 0 to be created. Value of numShards is 2 and
value of replicationFactor is 1. This requires 2 shards to be created
(higher than the allowed number)

I get the same error with createNodeSet=s1:8983,s2:8983,s3:8983,s4:8983 with
all four Solr hosts running.

But the service status command shows that Zookeeper sees all my running
nodes
--------------------------------------------------------------------------------
Solr process 24603 running on port 8983
{
  "solr_home":"/volume/solr/data/",
  "version":"5.1.0 1672403 - timpotter - 2015-04-09 10:37:54",
  "startTime":"2015-06-02T18:00:06.665Z",
  "uptime":"0 days, 0 hours, 4 minutes, 35 seconds",
  "memory":"19.6 MB (%4) of 490.7 MB",
  "cloud":{
    "ZooKeeper":"zk1:2181,zk2:2181,k3:2181",
    "liveNodes":"4",
    "collections":"0"}}


I was expecting the absent maxShardsPerNode param to default to 1 and give
me 2 leaders, 2 replicas.



--
View this message in context: http://lucene.472066.n3.nabble.com/SolrCloud-5-1-startup-looking-for-standalone-config-tp4209118p4209294.html
Sent from the Solr - User mailing list archive at Nabble.com.

Mime
View raw message