lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Blythe <j...@curvolabs.com>
Subject Re: No results for MoreLikeThis
Date Tue, 26 May 2015 20:24:03 GMT
Just checked my schema.xml and think that the issue is resulting from the
"stored" property being set false on descript2 and true on descript.


-- 
*John Blythe*
Product Manager & Lead Developer

251.605.3071 | john@curvolabs.com
www.curvolabs.com

58 Adams Ave
Evansville, IN 47713

On Tue, May 26, 2015 at 4:22 PM, John Blythe <john@curvolabs.com> wrote:

> Good call.
>
> I'd previously attempted to use one of my fields, however, and it didn't
> work. I then thought maybe broadening it to list anything could help. I'd
> tried using the interestingTerms parameter as well.
>
> Just for the sake of double checking before replying to your message,
> though, I changed fl once more to the field I was hoping to find items
> related to. I had a typo, though, and it worked. Instead of 'descript2' I
> used 'descript' and voila. 'descript' is the indexed field, descript2 is a
> copyField that uses a different analyzer (the one I'm actually using for
> querying). I guess it only takes non-copy (and maybe non-dynamic?) fields
> into account?
>
> Thanks for any more information on that field specific approach/issue!
>
> --
> *John Blythe*
> Product Manager & Lead Developer
>
> 251.605.3071 | john@curvolabs.com
> www.curvolabs.com
>
> 58 Adams Ave
> Evansville, IN 47713
>
> On Tue, May 26, 2015 at 4:16 PM, Upayavira <uv@odoko.co.uk> wrote:
>
>> I doubt mlt.fl=* will work. Provide it with specific field names that
>> should be used for the comparison.
>>
>> Upayavira
>>
>> On Tue, May 26, 2015, at 08:17 PM, John Blythe wrote:
>> > hi all,
>> >
>> > running a query like this, but am getting no results from the mlt
>> > handler:
>> > http://localhost:8983/solr/parts/select?q=mfgname2%3A+Acme
>> >
>> Corp+descript2%3A+(SCREW+3.5X50MM)&start=0&rows=1&fl=*%2C+score&wt=json&indent=true&mlt=true&mlt.fl=*&mlt.mintf=1&mlt.mindf=1&mlt.minwl=1
>> >
>> > been googling around without any luck as of yet. i have the
>> > requestHandler
>> > added to solrconfig.xml:
>> > <requestHandler name="/mlt" class="solr.MoreLikeThisHandler" />
>> >
>> > and confirm it is loaded in the Plugins/Stats area of the solr admin
>> > interface.
>> >
>> > i've tried adding minimum word length, term frequency, etc. per a post
>> or
>> > two i ran across where people had similar issues resolved by doing so,
>> > but
>> > it didn't help any.
>> >
>> > i'm not getting any errors, what puzzle piece am i missing in my
>> > configuration or query building?
>> >
>> > thanks!
>> >
>> > - john
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message