lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Kuiper <matt.kui...@issinc.com>
Subject RE: Search in Solr Index
Date Mon, 20 Apr 2015 15:51:32 GMT
What type of field are you using? String?  If so try another type, like text_general.

I believe with type String the contents are stored in the index exactly as they are inputted
into the index.  So a search hit will have to match exactly the full value of the field, I
assume in your case "Birmingham" is only part of the value.  With text_general and other types,
the value will be tokenized and allow for hits on parts or variants of the value.

Matt


-----Original Message-----
From: Vijaya Narayana Reddy Bhoomi Reddy [mailto:vijaya.bhoomireddy@whishworks.com] 
Sent: Monday, April 20, 2015 9:31 AM
To: solr-user@lucene.apache.org
Subject: Search in Solr Index

Hi,

I am indexing some data from a Database. Data is getting indexed properly and when I query
in the Solr stock UI with query parameters as *.*, I could see the documents with all the
fields listed and as well the numFound reflecting properly. However,  if I perform a query
with a simple string  for example "Birmingham", numFound returns 0 with no records to be displayed.
There are records which are indexed that contains fields with the text "Birmingham". In the
schema.xml, all the fields have been defined as indexed="true" and stored="true"

This is happening for any search query string. What could be the reason for this behavior?


Thanks & Regards
Vijay

--
The contents of this e-mail are confidential and for the exclusive use of the intended recipient.
If you receive this e-mail in error please delete it from your system immediately and notify
us either by e-mail or telephone. You should not copy, forward or otherwise disclose the content
of the e-mail. The views expressed in this communication may not necessarily be the view held
by WHISHWORKS.
Mime
View raw message