lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: SOLR 5.0.0 and Tomcat version ?
Date Mon, 23 Mar 2015 19:05:31 GMT
The argument is that "you don't run a SQL engine from a servlet
container, why should you run Solr that way?" Currently 5.x does have
a war file in the webapps directory you can use. As Alexandre says,
though, people are being encouraged to move away from that model and
use the script way of doing things.

And to be clear. "The script way of doing things" still listens on a
port for HTTP calls, still processes them, etc., etc., etc. Once you
start it up, it's just a Solr server listening on a port, like a bunch
of other services. It just doesn't need a servlet container in the
middle. Or, more accurately, end users shouldn't have to care about
what kind of thing Solr is using to listen.

Best,
Erick

On Mon, Mar 23, 2015 at 11:46 AM, Vishal Swaroop <vishal.rec@gmail.com> wrote:
> a) Does this means that SOLR 5 cannot be deployed on Tomcat or it is not
> worth.
>
>
> Regards
> Vishal
>
> On Mon, Mar 23, 2015 at 2:27 PM, Adnan Yaqoob <itsadnan@gmail.com> wrote:
>
>> Erick,
>> Any specific reason for going away from war file?
>>
>> Adnan
>>
>> On Mon, Mar 23, 2015 at 12:35 PM, Erick Erickson <erickerickson@gmail.com>
>> wrote:
>>
>> > There will be no war file distributed for a start....
>> >
>> > Best,
>> > Erick
>> >
>> > On Mon, Mar 23, 2015 at 9:04 AM, Karl Kildén <karl.kilden@gmail.com>
>> > wrote:
>> > > Just curious, what will be done that is incompatible with servlet
>> > > containers?
>> > >
>> > >
>> > >
>> > > On 23 March 2015 at 16:50, Aman Tandon <amantandon.10@gmail.com>
>> wrote:
>> > >
>> > >> Hi Vishal,
>> > >>
>> > >> I am not aware of which version of tomcat will suit best. But I will
>> > >> suggest to use Solr as it is, because after few more release solr will
>> > not
>> > >> be able to run using application server.
>> > >>
>> > >> So its good to use it as it is (without application server) when you
>> are
>> > >> redesigning the structure again.
>> > >>
>> > >> With Regards
>> > >> Aman Tandon
>> > >>
>> > >> On Mon, Mar 23, 2015 at 9:09 PM, Vishal Swaroop <vishal.rec@gmail.com
>> >
>> > >> wrote:
>> > >>
>> > >> > Hi,
>> > >> >
>> > >> > We are planning to configure new linux server for latest SOLR
>> release
>> > >> i.e.
>> > >> > 5.0.0
>> > >> >
>> > >> > Please suggest which Tomcat version will be best compatible with
>> > SOLR5...
>> > >> > latest Tomcat release is 8.0
>> > >> >
>> > >> > Thanks
>> > >> >
>> > >>
>> >
>>
>>
>>
>> --
>> Regards,
>> *Adnan Yaqoob*
>>

Mime
View raw message