lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CKReddy Bhimavarapu <chaitu...@gmail.com>
Subject Re: Setting Up an External ZooKeeper Ensemble
Date Tue, 24 Feb 2015 11:43:46 GMT
yes

> chaitanya@imart-desktop:~/solr/zookeeper-3.4.6/bin$ ./zkServer.sh start
>
> JMX enabled by default
> Using config: /home/chaitanya/solr/zookeeper-3.4.6/bin/../conf/zoo.cfg
> Starting zookeeper ... STARTED
> chaitanya@imart-desktop:~/solr/zookeeper-3.4.6/bin$ ./zkServer.sh status
> JMX enabled by default
> Using config: /home/chaitanya/solr/zookeeper-3.4.6/bin/../conf/zoo.cfg
> Error contacting service. It is probably not running
>
> but I don't get why it is not running


On Tue, Feb 24, 2015 at 1:45 PM, Shalin Shekhar Mangar <
shalinmangar@gmail.com> wrote:

> Looks like the ZooKeeper server is either not running or not accepting
> connection possibly because of some configuration issues. Can you look into
> the ZooKeeper logs and see if there are any exceptions?
>
> On Tue, Feb 24, 2015 at 11:30 AM, CKReddy Bhimavarapu <chaitu949@gmail.com
> >
> wrote:
>
> > Hi,
> >   I did follow all the steps in [
> >
> >
> https://cwiki.apache.org/confluence/display/solr/Setting+Up+an+External+ZooKeeper+Ensemble
> > ]
> > but still I am getting this error
> > <b>Waiting to see Solr listening on port 8983 [-]  Still not seeing Solr
> > listening on 8983 after 30 seconds!</b>
> > WARN  - 2015-02-24 05:50:19.161;
> > org.apache.zookeeper.ClientCnxn$SendThread; Session 0x0 for server null,
> > unexpected error, closing socket connection and attempting reconnect
> > java.net.ConnectException: Connection refused
> > at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
> > at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:739)
> > at
> >
> >
> org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:361)
> > at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1081)
> > WARN  - 2015-02-24 05:50:20.262;
> > org.apache.zookeeper.ClientCnxn$SendThread; Session 0x0 for server null,
> > unexpected error, closing socket connection and attempting reconnect
> >
> >
> > Where am I going wrong?
> >
> > --
> > ckreddybh. <chaitu949@gmail.com>
> >
>
>
>
> --
> Regards,
> Shalin Shekhar Mangar.
>



-- 
ckreddybh. <chaitu949@gmail.com>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message