lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arcadius Ahouansou <arcad...@menelic.com>
Subject Re: Solr I/O increases over time
Date Sat, 24 Jan 2015 10:30:24 GMT
On 23 January 2015 at 22:52, Daniel Cukier <danicuki@gmail.com> wrote:

> I am running around eight solr servers (version 3.5) instances behind a
> Load Balancer. All servers are identical and the LB is weighted by number
> connections. The servers have around 4M documents and receive a constant
> flow of queries. When the solr server starts, it works fine. But after some
> time running, it starts to take longer respond to queries, and the server
> I/O goes crazy to 100%. Look at the New Relic graphic:
>
> [image: enter image description here]
>
> If the servers behaves well in the beginning, I it starts to fail after
> some time? Then if I restart the server, it gets back to low I/O for same
> time and this repeats over and over.
> Daniel Cukier
>


Hello Daniel.
Your I/O issue may be due to clients not always closing/releasing
connections to the Solr Server, or not having a timeout set on the clients
I would suggest that when the incident occurs, you run netstat on the Solr
boxes.
Chances are,  a lot of connections would be in CLOSE_WAIT or TIME_WAIT
state.

Thanks.

Arcadius.

-- 
Arcadius Ahouansou
Menelic Ltd | Information is Power
M: 07908761999
W: www.menelic.com
---

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message