lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Hatcher <erik.hatc...@gmail.com>
Subject Re: SimplePostTool with extracted Outlook messages
Date Tue, 27 Jan 2015 10:57:48 GMT
Try adding -Dauto=true and take away setting url.  The type probably isn't needed then either.


With the new Solr 5 bin/post it sets auto=true implicitly.  

    Erik


> On Jan 26, 2015, at 17:29, Mark <javamark@gmail.com> wrote:
> 
> Fantastic - that explians it
> 
> Adding -Durl="
> http://localhost:8983/solr/update/extract?commit=true&overwrite=true"
> 
> Get's me a little further
> 
> POSTing file 000000006252671B765A1748992DF1A6403BDF81A4A22E00.msg
> SimplePostTool: WARNING: Solr returned an error #400 (Bad Request) for url:
> http://localhost:8983/solr/update/extract?commit=true&overwrite=true
> SimplePostTool: WARNING: Response: <?xml version="1.0" encoding="UTF-8"?>
> <response>
> <lst name="responseHeader"><int name="status">400</int><int
> name="QTime">44</int></lst><lst name="error"><str name="msg">Document
is
> missing mandatory uniqueKey field: id</str><int name="cod
> e">400</int></lst>
> </response>
> 
> However not much use when recursing a directory and the URL essentially has
> to change to pass the document ID
> 
> I think I may just extend SimplePostToo or look to use Solr Cell perhaps?
> 
> 
> 
> On 26 January 2015 at 22:14, Alexandre Rafalovitch <arafalov@gmail.com>
> wrote:
> 
>> Well, you are NOT posting to the same URL.....
>> 
>> 
>>> On 26 January 2015 at 17:00, Mark <javamark@gmail.com> wrote:
>>> http://localhost:8983/solr/update
>> 
>> 
>> 
>> ----
>> Sign up for my Solr resources newsletter at http://www.solr-start.com/
>> 

Mime
View raw message