lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "S.L" <simpleliving...@gmail.com>
Subject Re: distrib=false
Date Sun, 28 Dec 2014 15:48:51 GMT
Erik

I have attached the screen shot of the toplogy , as you can see I have
three nodes and no two replicas of the same shard reside on the same node,
this was made sure so as not affect the availability.

The query that I use is a general get all query of type *:* to test .

The behavior I notice is that even though when a particular replica of a
shard is queried using distrib=false , the request goes to the other
replica of the same shard.

Thanks.

On Sat, Dec 27, 2014 at 2:10 PM, Erick Erickson <erickerickson@gmail.com>
wrote:

> How are you sending the request? AFAIK, setting distrib=false
> should should keep the query from being sent to any other node,
> although I'm not quite sure what happens when you host multiple
> replicas of the _same_ shard on the same node.....
>
> So we need:
> 1> your topology, How many nodes and what replicas on each?
> 2> the actual query you send.
>
> Best,
> Erick
>
> On Sat, Dec 27, 2014 at 8:14 AM, S.L <simpleliving016@gmail.com> wrote:
> > Hi All,
> >
> > I have a question regarding distrib=false on the Solr query , it seems
> that
> > the distribution is restricted across only the shards  when the parameter
> > is set to false, meaning if I query a particular node with in a shard
> with
> > replication factor of more than one  , the request could go to another
> node
> > with in the same shard which is a replica of the node that I made the
> > initial request to, is my understanding correct ?
> >
> > If the answer to my question is yes, then how do we make sure that the
> > request goes to only the node I intend to make the request to  ?
> >
> > Thanks.
>

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message