lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guido Medina <guido.med...@temetra.com>
Subject Re: Solr Error when making GeoPrefixTree polygon filter search
Date Wed, 10 Dec 2014 23:09:50 GMT
Hi Mathaix,

David could be right, we have geo-polygons and stuff and what we do is 
that we put the JTS jar inside solr.war (and other jars using our own 
automated scripts to add extra jars inside it)

Here is the link of latest maven JTS dependency where you can download 
it directly:

http://search.maven.org/#artifactdetails|com.vividsolutions|jts|1.13|jar

HTH,

Guido.

On 10/12/14 22:27, david.w.smiley@gmail.com wrote:
> Mathaix,
> I bet you don’t have JTS on your classpath.  See the spatial page in the
> Solr ref guide.
>
> ~ David Smiley
> Freelance Apache Lucene/Solr Search Consultant/Developer
> http://www.linkedin.com/in/davidwsmiley
>
> On Wed, Dec 10, 2014 at 4:50 PM, mathaix <mmathew@placester.com> wrote:
>
>> So I downloaded and attached the spatial4j source. (where it is breaking).
>> Notice that there is no POLYGON type in the WktShapeParser file.
>>
>> (See attached source).
>>
>> https://github.com/spatial4j/spatial4j/blob/master/src/main/java/com/spatial4j/core/io/WktShapeParser.java
>>
>>
>>
>> --
>> View this message in context:
>> http://lucene.472066.n3.nabble.com/Solr-Error-when-making-GeoPrefixTree-polygon-filter-search-tp4173629p4173650.html
>> Sent from the Solr - User mailing list archive at Nabble.com.
>>


Mime
View raw message