lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kamal Kishore Aggarwal <kkroyal....@gmail.com>
Subject Integrate NLP to solr
Date Thu, 10 Jul 2014 07:33:11 GMT
Dear Team,

I am working on solr 4.8.1 version. I want to integrate solr with NLP in
order to improve the search relevancy. I am following the tutorials:

https://wiki.apache.org/solr/OpenNLP
https://issues.apache.org/jira/browse/LUCENE-2899

Its says:

   - pull the latest trunk or 4.0 branch
   -

   apply the latest LUCENE-2899
   <https://issues.apache.org/jira/browse/LUCENE-2899> patch
   - do 'ant compile'
   - cd solr/contrib/opennlp/src/test-files/training
   - run 'bin/trainall.sh'

What I have done is:

-> Downloaded solr-4.8.1 in /data/ -> cd /data/solr-4.8.1/; -> Downloaded
all four files from issues.apache.org/jira/browse/LUCENE-2899; -> patch -p0
-i LUCENE-2899.patch Getting the following error: can't find file to patch
at input line 5 Perhaps you used the wrong -p or --strip option?

I am failing :(.   Please help.


Regards
Kamal Kishore

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message