lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Hostetter <hossman_luc...@fucit.org>
Subject Re: Cannot run program "svnversion" when building lucene 4.7.1
Date Sat, 05 Apr 2014 01:18:49 GMT

: > I am trying to build lucene 4.7.1 from the sources. I can compile without
: > any issues but when I try to build the dist, lucene gives me
: > Cannot run program "svnversion" ... The system cannot find the specified
: > file.
: >
: > I am compiling on Windows 7 64-bit using java version 1.7.0.45 64-bit.

That's ... strange.

the build system *attempts* to include the svnversion info in the build 
artifacts, but it is explicitly designed to not fail if svnversion can't 
be run.

Can you pleae file a bug, note in the description your specific OS 
setup, and include as an attachment the full build logs you get from ant 
that give you this error?  ideally run ant using the "-v" option.


worst case scenerio: you should be able to override the "svnversion.exe" 
build property to some simple command that doesn't output much (not 
sure what a good command to use on windows might be - i would use 
something like "whoami" on linux if i din't have svn installed). 

the command would be something like this...

  ant -Dsvnversion.exe=whoami dist



-Hoss
http://www.lucidworks.com/

Mime
View raw message