lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: Stemming not working with wildcard search
Date Wed, 30 Apr 2014 15:19:21 GMT
Did you re-index? And what do you get when adding &debug=query? That
should show you the parsed query. Have you looked at the results of
the admin/analysis page? That tool is invaluable for seeing what the
actual transformations are.

Best,
Erick

On Mon, Apr 28, 2014 at 11:41 AM, Geepalem <naresh.geepalem@yahoo.com> wrote:
> Hi Ahmet,
>
> Thanks for your prompt response!
>
> I have added filters which you have specified but still its not working.
> Below is field Query Analyzer
>
>  <analyzer type="query">
>         <tokenizer class="solr.StandardTokenizerFactory" />
>         <filter class="solr.LowerCaseFilterFactory" />
>
>         <filter class="solr.KeywordRepeatFilterFactory"/>
>         <filter class="solr.PorterStemFilterFactory"/>
>         <filter class="solr.RemoveDuplicatesTokenFilterFactory"/>
>  </analyzer>
>
> http://localhost:8080/solr/master/select?q=page_title_t:*products*
> http://localhost:8080/solr/master/select?q=page_title_t:*product*
>
>
> Please let me know if I am doing anything wrong.
>
> Thanks,
> G. Naresh Kumar
>
>
>
> --
> View this message in context: http://lucene.472066.n3.nabble.com/Stemming-not-working-with-wildcard-search-tp4133382p4133556.html
> Sent from the Solr - User mailing list archive at Nabble.com.

Mime
View raw message