lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <s...@elyograg.org>
Subject Re: Server vs Client - JDK compatibility
Date Wed, 08 Jan 2014 06:20:23 GMT
On 1/7/2014 10:19 PM, Gnanam wrote:
> Shawn Heisey-4 wrote
>> Although SolrJ is a standalone component, it is also an integral part of
>> Solr itself, so it has the same Java requirement as Solr.  It is highly
>> unlikely that it will work at all with a 1.3.x Java version.
> 
> Thanks Shawn.  So which version of Solr supports JDK 1.3?  Or any
> pointers/way to figure out this from the archive/previous release folder?

I was able to easily find requirements on versions back to Solr 1.1 -
which requires Java 1.5.

Java 1.3 was released in 2000, 1.4 in 2002, and 1.5 in 2004.  Solr was
initially created in 2004, and was open sourced in 2006, so I would
expect that all the early publicly available Solr versions required Java
1.5.

http://en.wikipedia.org/wiki/Java_version_history#J2SE_1.3_.28May_8.2C_2000.29

http://en.wikipedia.org/wiki/Apache_Solr#History

I don't think you'll be able to use *any* version of SolrJ with a 1.3
JVM.  It may even be difficult to find compatible HTTP and XML libraries
to roll your own client like Hoss advised.  That Java version is *OLD*.

Thanks,
Shawn


Mime
View raw message