lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: SolrCloud - BadRequest error when adding records
Date Fri, 29 Nov 2013 00:38:35 GMT
How are you trying to update? This looks like the intra-shard URL,
What's the process by which you attempt to add the docs?

Best,
Erick


On Thu, Nov 28, 2013 at 12:20 PM, Puneet Pawaia <puneet.pawaia@gmail.com>wrote:

> Hi All,
>
> I have an test setup with External Zookeeper and 2 machines with Solr
> 4.6.0. 2 collections with 2 shards. As such there is no replica at the
> moment.
>
> However, when adding records, I am getting the following error
>
> ERROR - 2013-11-28 22:42:26.925;
> org.apache.solr.update.StreamingSolrServers$1; error
> org.apache.solr.common.SolrException: Bad Request
>
> request:
>
> http://192.168.0.10:8983/solr/test/update?update.distrib=TOLEADER&distrib.from=http%3A%2F%2F192.168.0.9%3A8983%2Fsolr%2Ftest%2F&wt=javabin&version=2
>         at
>
> org.apache.solr.client.solrj.impl.ConcurrentUpdateSolrServer$Runner.run(ConcurrentUpdateSolrServer.java:240)
>         at
>
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
>         at
>
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
>         at java.lang.Thread.run(Thread.java:724)
>
> Don't know what could be the problem.
>
> TIA
> Regards
> Puneet Pawaia
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message