lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Furkan KAMACI <furkankam...@gmail.com>
Subject Solr 4.5.1 Startup Problem
Date Thu, 28 Nov 2013 15:03:11 GMT
I use Solr 4.5.1 I have a configuration from Solr 4.3. When I start my Solr
I get that exception:

org.apache.solr.common.SolrException: Could not load config for
solrconfig.xml
at
org.apache.solr.core.CoreContainer.createFromLocal(CoreContainer.java:919)
at org.apache.solr.core.CoreContainer.create(CoreContainer.java:984)
at org.apache.solr.core.CoreContainer$2.call(CoreContainer.java:597)
at org.apache.solr.core.CoreContainer$2.call(CoreContainer.java:592)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
at java.util.concurrent.FutureTask.run(FutureTask.java:166)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
at java.util.concurrent.FutureTask.run(FutureTask.java:166)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:724)
Caused by: org.apache.solr.common.SolrException: Invalid luceneMatchVersion
'4.5', valid values are: [LUCENE_30, LUCENE_31, LUCENE_32, LUCENE_33,
LUCENE_34, LUCENE_35, LUCENE_36, LUCENE_40, LUCENE_41, LUCENE_42,
LUCENE_43, LUCENE_CURRENT] or a string in format 'V.V'
at org.apache.solr.core.Config.parseLuceneVersionString(Config.java:424)
at org.apache.solr.core.Config.getLuceneVersion(Config.java:409)
at org.apache.solr.core.SolrConfig.<init>(SolrConfig.java:121)
at
org.apache.solr.core.CoreContainer.createFromLocal(CoreContainer.java:916)
... 11 more

What should I change? I have 4.5 as lucenematchversion.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message