lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shawn Heisey <s...@elyograg.org>
Subject Re: Solr 4.5.1 Overseer error
Date Tue, 29 Oct 2013 00:54:34 GMT
On 10/28/2013 5:50 PM, dboychuck wrote:
> I am upgrading from 4.4 to 4.5.1
>
>   I used to just upload my configurations to zookeeper and then install solr
> with no default core
> Solr would give me an error that no cores were created when I tried to
> access until I ran the collections API create command to make a collection
>
> however now when I try to install solr with no default core I get a generic
> error about path cannot end with "/" and I can't create the cores using the
> collections api
>
> when I manually copy the files over and create the core through the
> interface it all works as expected
> any help would be appreciated

Working on IRC, we were able to track this down to a work item in the 
overseer queue in zookeeper.  It had a "deletecore" operation in the 
queue with the "collection" parameter set to an empty string.

{
"operation":"deletecore",
"core_node_name":"solr-shard-1.REDACTED.com:__collection1",
   "core":"collection1",
   "collection":"",
"node_name":"solr-shard-1.REDACTED.com:_"}

Basically, the previous version left behind some bad data in zookeeper.  
When dboychuck wiped out all the zookeeper data and started over, it all 
worked.

If you are seeing "Path must not end with / character" error when 
starting Solr, you may have some bad data in the overseer queue, which 
is located in zookeeper.

Would it be worthwhile to file a bug so Solr can deal with these 
problems automatically and log what it's doing, or at the very least 
output a better error message?

Thanks,
Shawn


Mime
View raw message