lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erick Erickson <erickerick...@gmail.com>
Subject Re: very simple boolean query not working
Date Tue, 13 Aug 2013 12:23:54 GMT
Not quite sure what you're seeing here. adding &debugQuery=true
shows the parsed query, timings, things like that. What it does NOT
do is show you how things were scored.

If you have a document that you think should match, you can add
explainOther to the query and it'll show you how an arbitrary
document would be scored, see:
http://wiki.apache.org/solr/CommonQueryParameters#explainOther

Best
Erick


On Mon, Aug 12, 2013 at 1:50 PM, S L <sol.lederman@gmail.com> wrote:

> Jack Krupansky-2 wrote
> > Also, be aware that the spaces in your query need to be URL-encoded.
> > Depending on how you are sending the command, you may have to do that
> > encoding yourself.
> >
> > -- Jack Krupansky
>
> It's a good possibility that that's the problem. I've been doing queries in
> different ways (browser, curl, input from other programs...) and haven't
> thought lately about the encoding of spaces. I won't get a chance to check
> the encoding until tonight but I'll report back later.
>
> Thanks very much.
>
>
>
>
> --
> View this message in context:
> http://lucene.472066.n3.nabble.com/very-simple-boolean-query-not-working-tp4083895p4084054.html
> Sent from the Solr - User mailing list archive at Nabble.com.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message