lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Matheis <matheis.ste...@gmail.com>
Subject Re: Different Responses for 4.4 and 3.5 solr index
Date Mon, 26 Aug 2013 13:46:23 GMT
Did you check the scoring? (use fl=*,score to retrieve it) .. additionally debugQuery=true
might provide more information about how the score was calculated.

- Stefan 


On Monday, August 26, 2013 at 12:46 AM, Kuchekar wrote:

> Hi,
> The response from 4.4 and 3.5 in the current scenario differs in the
> sequence in which results are given us back.
> 
> For example :
> 
> Response from 3.5 solr is : id:A, id:B, id:C, id:D ...
> Response from 4.4 solr is : id C, id:A, id:D, id:B...
> 
> Looking forward your reply.
> 
> Thanks.
> Kuchekar, Nilesh
> 
> 
> On Sun, Aug 25, 2013 at 11:32 AM, Stefan Matheis
> <matheis.stefan@gmail.com (mailto:matheis.stefan@gmail.com)>wrote:
> 
> > Kuchekar (hope that's your first name?)
> > 
> > you didn't tell us .. how they differ? do you get an actual error? or does
> > the result contain documents you didn't expect? or the other way round,
> > that some are missing you'd expect to be there?
> > 
> > - Stefan
> > 
> > 
> > On Sunday, August 25, 2013 at 4:43 PM, Kuchekar wrote:
> > 
> > > Hi,
> > > 
> > > We get different response when we query 4.4 and 3.5 solr using same
> > > query params.
> > > 
> > > My query param are as following :
> > > 
> > > facet=true
> > > &facet.mincount=1
> > > &facet.limit=25
> > > 
> > 
> > &qf=content^0.0+p_last_name^500.0+p_first_name^50.0+strong_topic^0.0+first_author_topic^0.0+last_author_topic^0.0+title_topic^0.0
> > > &wt=javabin
> > > &version=2
> > > &rows=10
> > > &f.affiliation_org.facet.limit=150
> > > &fl=p_id,p_first_name,p_last_name
> > > &start=0
> > > &q=Apple
> > > &facet.field=affiliation_org
> > > &fq=table:profile
> > > &fq=num_content:[*+TO+1500]
> > > &fq=name:"Apple"
> > > 
> > > The content in both (solr 4.4 and solr 3.5) are same.
> > > 
> > > The solrconfig.xml from 3.5 an 4.4 are similarly constructed.
> > > 
> > > Is there something I am missing that might have been changed in 4.4,
> > which
> > > might be causing this issue. ?. The "qf" params looks same.
> > > 
> > > Looking forward for your reply.
> > > 
> > > Thanks.
> > > Kuchekar, Nilesh
> > > 
> > 
> > 
> 
> 
> 



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message