lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Xiang <Kevin.Xi...@morningstar.com>
Subject RE: Solr 4.2 in SolrCloud mode lost response for update but search is normal
Date Thu, 20 Jun 2013 05:31:16 GMT
From the coredump information,it seem that the issue is the same as the jira:
https://issues.apache.org/jira/browse/SOLR-4400: Rapidly opening and closing cores can lead
to deadlock
Mark Miller:
Does the issue happen again?

Thanks.
From: Qun Wang
Sent: 2013年6月20日 11:24
To: <solr-user@lucene.apache.org> (solr-user@lucene.apache.org)
Subject: Solr 4.2 in SolrCloud mode lost response for update but search is normal

Hi, all:

I’m using SolrCloud with Solr 4.2, and currently a strange issue often happen and confuse
me.
The running env has three zookeepers and two solrs, used the same shard and six cores.
Without any network and resource issue, I found that after a time, solr would lost response
for update but query is normal.
Servers neither process any update nor generate response info, seems somewhere entered a dead
lock.
Thread dump info for on machine is attached.

Could someone help me check what’s the root issue?

Thanks!
__________________________________________________________________________________________
Qun Wang
Application Service - Backend
Morningstar (Shenzhen) Ltd.
Morningstar. Illuminating investing worldwide.
+86 755 3311 0218 Office
+86 186 6538 3975 Mobile
Qun.Wang@morningstar.com<mailto:Qun.Wang@morningstar.com%0d>
This e-mail contains privileged and confidential information and is intended only for the
use of the person(s) named above. Any dissemination, distribution or duplication of this communication
without prior written consent from Morningstar is strictly prohibited. If you received this
message in error please contact the sender immediately and delete the materials from any computer.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message