lucene-solr-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexandre Rafalovitch <arafa...@gmail.com>
Subject Re: How to get/set customized Solr data source properties?
Date Tue, 14 May 2013 01:15:59 GMT
If the property has a full stop, it is probably going through the
scoped resolver which may be causing issues. I would start with very
basic property name format and see what happens.

Otherwise, it is probably a breakpoint and debug time.

Regards,
   Alex.
Personal blog: http://blog.outerthoughts.com/
LinkedIn: http://www.linkedin.com/in/alexandrerafalovitch
- Time is the quality of nature that keeps events from happening all
at once. Lately, it doesn't seem to be working.  (Anonymous  - via GTD
book)


On Mon, May 13, 2013 at 6:08 PM, Chris Hostetter
<hossman_lucene@fucit.org> wrote:
>
> : learned it should work. And this is my actual code. I create this
> : DataSource for testing my ideas. I am blocked at the very beginning...sucks
> : :(
>
> but you only showed us one line of code w/o any context.  nothing in your
> email was reproducible for other people to try to compile/run themselves
> to see if htey can figure out why your code isn't working.
>
> : > : I am working on a DataSource implementation. I want to get some
> : > customized
> : > : properties when the *DataSource.init* method is called. I tried to add
> : > the
> : >         ...
> : > :     <dataConfig>
> : > :       <dataSource type="com.my.company.datasource"
> : > :         my="value" />
> : >
> : > My understanding from looking at other DataSources is that should work.
> : >
> : > : But initProps.getProperty("my") == null.
> : >
> : > can you show us some actual that fails with that dataConfig you mentioned?
>
>
> -Hoss

Mime
View raw message